Shestak UI
Go Back   Shestak UI > Interface Forums > English Community > Bugs Reports

Bugs Reports Report any bugs or issues you come across with ShestakUI.

Advertising

 
Thread Tools
Old 12.02.2012, 22:13   #1
 Elder Member User Information

jenderle7's Avatar
Bug Errors with latest commit

Ever since I downloadled the latest commit I get a total of 47 errors at login and reloads. Most were related to btn in functions, mirrorbar issues, cursor offset, and something about lootrolls. I've downloadled it twice and loaded only Shestakui including deleting the cache and wtf folders but to no avail. Any thoughts?
Old 12.02.2012, 22:13   #1.5 - Disable Ads

Advertise on this site

Old 12.02.2012, 22:37   #2
Shestak
 Junior Member User Information

Shestak's Avatar
Quote:
Originally Posted by jenderle7 View Post
Ever since I downloadled the latest commit I get a total of 47 errors at login and reloads.
So you do something wrong.
Old 13.02.2012, 01:11   #3
jenderle7
 Elder Member User Information

jenderle7's Avatar
Quote:
Originally Posted by Shestak View Post
Quote:
Originally Posted by jenderle7 View Post
Ever since I downloadled the latest commit I get a total of 47 errors at login and reloads.
So you do something wrong.
I just deleted everything once again and upon logging in everything is fine. As soon as I use your in game config and reload I get the same errors. I've been using this UI for about a year and I generally know some coding but I don't see how this could be on my end.
Old 13.02.2012, 01:26   #4
Shestak
 Junior Member User Information

Shestak's Avatar
Quote:
Originally Posted by jenderle7 View Post
I get the same errors.
What errors?!
Old 13.02.2012, 01:28   #5
jenderle7
 Elder Member User Information

jenderle7's Avatar
I just went through the config and its when I enable styling blizzard frames that all the errors pop up. I would post them but there are 47
Old 13.02.2012, 01:28   #6
Shestak
 Junior Member User Information

Shestak's Avatar
Quote:
Originally Posted by jenderle7 View Post
I would post them but there are 47
First error.
Old 13.02.2012, 01:32   #7
jenderle7
 Elder Member User Information

jenderle7's Avatar
Code [Select]:
Message: Interface\AddOns\ShestakUI\Core\Functions.lua:366: attempt to index local 'btn' (a nil value)
Time: 02/12/12 17:31:28
Count: 1
Stack: Interface\AddOns\ShestakUI\Core\Functions.lua:366: in function `SkinNextPrevButton'
...e\AddOns\ShestakUI\Modules\Skins\Blizzard\Others.lua:236: in function <...e\AddOns\ShestakUI\Modules\Skins\Blizzard\Others.lua:8>

Locals: btn = nil
horizonal = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = "attempt to index local 'btn' (a nil value)"
Old 13.02.2012, 01:43   #8
Shestak
 Junior Member User Information

Shestak's Avatar
Let's try again.

1:
What version of WoW.
What version of ShestakUI.
The list of installed addons.

2:
In your WoW\Interface\AddOns\ folder, delete all ShestakUI* folders.
In your WTF\Account\*****\ folder, delete all ShestakUI* files.
Download and install latest ShestakUI from guthub https://github.com/Shestak/ShestakUI .
Log into the game without setting anything in ShestakUI.

There are errors?

Posted in 1 minute
Quote:
Originally Posted by jenderle7 View Post
I would post them but there are 47
And the second error please.
Old 13.02.2012, 01:51   #9
jenderle7
 Elder Member User Information

jenderle7's Avatar
1. WOW version 4.3.2
ShestakUI version 3.4.1
Only ShestakUi addons installed....including your extras folder
2. I did all that. When I first log in everything is fine. As soon as I check the enable stylizing Blizzard frames and apply I receive all the errors.


Second error-
Code [Select]:
...ace\AddOns\ShestakUI\Modules\Blizzard\MirrorBars.lua:108: attempt to call field '?' (a nil value)
Time: 02/12/12 17:50:43
Count: 3
Stack: ...ace\AddOns\ShestakUI\Modules\Blizzard\MirrorBars.lua:108: in function <...ace\AddOns\ShestakUI\Modules\Blizzard\MirrorBars.lua:107>

Locals: self = <unnamed> {
 0 = <userdata>
 MIRROR_TIMER_START = <function> defined @Interface\AddOns\ShestakUI\Modules\Blizzard\MirrorBars.lua:131
 MIRROR_TIMER_STOP = <function> defined @Interface\AddOns\ShestakUI\Modules\Blizzard\MirrorBars.lua:136
 PLAYER_ENTERING_WORLD = <function> defined @Interface\AddOns\ShestakUI\Modules\Blizzard\MirrorBars.lua:121
 MIRROR_TIMER_PAUSE = <function> defined @Interface\AddOns\ShestakUI\Modules\Blizzard\MirrorBars.lua:141
}
event = "ADDON_LOADED"
(*temporary) = nil
(*temporary) = <unnamed> {
 0 = <userdata>
 MIRROR_TIMER_START = <function> defined @Interface\AddOns\ShestakUI\Modules\Blizzard\MirrorBars.lua:131
 MIRROR_TIMER_STOP = <function> defined @Interface\AddOns\ShestakUI\Modules\Blizzard\MirrorBars.lua:136
 PLAYER_ENTERING_WORLD = <function> defined @Interface\AddOns\ShestakUI\Modules\Blizzard\MirrorBars.lua:121
 MIRROR_TIMER_PAUSE = <function> defined @Interface\AddOns\ShestakUI\Modules\Blizzard\MirrorBars.lua:141
}
(*temporary) = "ShestakUI_Heal"
(*temporary) = "attempt to call field '?' (a nil value)"
Old 13.02.2012, 01:54   #10
Shestak
 Junior Member User Information

Shestak's Avatar
Quote:
Originally Posted by jenderle7 View Post
ShestakUI version 3.4.1
Only ShestakUi addons installed....including your extras folder
It is very strange.
In 3.4.0, these errors appear?

Thread Tools


Similar Threads
Thread Thread Starter Forum Replies Last Post
[Fixed] Actionbar errors in PTR tat2dawn Bugs Reports 2 12.11.2011 22:23


Mobile Style Русский English Deutsch Italian Chinese