Shestak UI
Go Back   Shestak UI > Interface Forums > English Community > Skinning

Skinning Share your custom skins with ShestakUI or others AddOns.


Thread Tools
Old 04.11.2012, 14:23   #1
 Junior Member User Information

TabulaRasa's Avatar
Lightbulb WeakAuras

Hi Shestak,

I've recently installed WeakAuras, and I want it to look like the rest of the interface.

I came across but I have no idea where to put the code. I tried a few, including creating a new .lua in modules/skins but it didn't work. Thanks for your help

Posted in 2 minutes
Also, how do I hide Filger cooldown icons so that I can entire replace those with WeakAuras? Thanks, I am a complete newbie at this.
Old 04.11.2012, 14:23   #1.5 - Disable Ads

Advertise on this site

Old 04.11.2012, 15:03   #2
 Senior Member User Information

Oz's Avatar
Skins options
"Enable styling WeakAuras"
For Filger, you have to manually change some settings.
Go to ShestakUI_Filger\Config\ and open Positions.lua and/or Settings.lua. I suggest you to use Notepad++ to do it. Remember to backup your changes or you will have to redo each time you update ShestakUI.
Say Thank:
Shestak (04.11.2012)
Old 04.11.2012, 16:05   #3
 Junior Member User Information

TabulaRasa's Avatar
I don't see any options under cfg to enable styling for WeakAuras.
Old 04.11.2012, 18:29   #4
 Senior Member User Information

Oz's Avatar
Originally Posted by TabulaRasa View Post
I don't see any options under cfg to enable styling for WeakAuras.
The option is here, in the config menu.
Old 05.11.2012, 02:31   #5
 Junior Member User Information

TabulaRasa's Avatar
Thanks! I had to update to 4.2.0--was on 4.1.9 -.-"
Old 15.10.2014, 05:04   #6
 Elder Member User Information

Balgar's Avatar
Clean Icons for WeakAuras

Pre Patch, my icons for WeakAuras were matched to ShestakUI, and were very clean with square borders. Now they are back to the ugly blizzard default icons. Can you suggest anything?
Old 15.10.2014, 08:18   #7
 Assistant User Information

Wetxius's Avatar
Skin for WeakAuras temporarily disabled.
At this moment only skins for BigWigs, DBM, Recount, Skada and TinyDPS are enabled. Others skins are untested and disabled.
Say Thank:
Shestak (15.10.2014)
Old 29.04.2017, 10:48   #8
 Elder Member User Information

Lamindra's Avatar
WeakAuras skin .lua-error


as of today I keep getting weird .lua-errors with the WeakAuras skin enabled:

Hidden text

Message: ...terface\AddOns\ShestakUI\Modules\Skins\WeakAuras.lua:29: ERROR: <unnamed>:SetFont(): invalid fontHeight: 0, height must be > 0
Time: 04/29/17 10:58:48
Count: 1
Stack: [C]: in function `SetFont'
...terface\AddOns\ShestakUI\Modules\Skins\WeakAuras.lua:29: in function `Skin_WeakAuras'
...terface\AddOns\ShestakUI\Modules\Skins\WeakAuras.lua:46: in function <...terface\AddOns\ShestakUI\Modules\Skins\WeakAuras.lua:10>

Locals: (*temporary) = <unnamed> {
0 = <userdata>
(*temporary) = "Interface\AddOns\ShestakUI\Media\Fonts\Pixel.ttf"
(*temporary) = 0
(*temporary) = "OUTLINEMONOCHROME"

Help is very much appreciated!

The error should be in

WeakAuras.lua Code [Select]:
select(2, frame.stacks:GetFont())

The moment I'm giving it a fixed value e.g. 16, it works again.

The error occurs when you set up a WeakAura as cooldown and not as %p aura. Changed everything back and it works again. Weird one for sure :/

I've found the actual problem: a misconfigured aura. Just for reference... if you setup an aura as a cooldown without text the resulting aura does not have a font that could be skinned -> error.

If you want a skinned cooldown aura you need to give it a custom function text with %c, but leave it empty. Maybe this will be helpful for someone!
Old 05.05.2017, 12:55   #9
 Assistant User Information

Wetxius's Avatar
Try replace ShestakUI\Modules\Skins\WeakAuras.lua by this

Thread Tools

Mobile Style Русский English Deutsch Italian Chinese